Author Topic: A&A on an old PC - input problem  (Read 2424 times)


  • Newbie
  • Posts: 1
  • Karma: +0/-0
    • View Profile
A&A on an old PC - input problem
« on: September 02, 2013, 05:37:03 AM »
EDIT: argh, I jumped with the thread too soon, sorry! Tried running the game on W98 session, instead of DOS - works like a charm! But just out of curiosity - is the problem below a common issue?

Hi and hello to all of you! I was pretty excited when I saw A&A, a total classic from my childhood, being released as freeware, and wanted to play the game in a true retro fashion - on my old PC, strictly for gaming. However - problems showed up.

Running the game on DOS 7.0, the sound effect and music works, but the game doesn't handle ANY input on the character select screen. This goes both to the mouse cursor (can't move) and the keyboard controls ([e]xit, [l]oad etc. keys do nothing). Out of curiosity I also tried the old abandonware version I downloaded from some site - guess what, the SAME problem occurs! Tried running the game with both HIMEM/EMM and HIMEMX/JEMM combos, nothing avail. I'm using CuteMouse DOS driver for the mouse, and the keyboard is a standard PS/2 one, is there any fix for this, or am I pretty much forced to stay with DosBox?

System specs:
PIII 1000 MHz
GeForce 2 Ti
256 MB RAM
Yamaha OPL3-SAx (ISA) soundcard
PS/2 mouse and keyboard
Windows 98SE / DOS 7.0
« Last Edit: September 02, 2013, 05:49:46 AM by Kurasiu »


  • Administrator
  • Full Member
  • Posts: 208
  • Karma: +6/-1
  • Is the potion half full or half empty?
    • View Profile
    • Amulets & Armor
Re: A&A on an old PC - input problem
« Reply #1 on: September 03, 2013, 08:24:38 PM »
I have not had anyone report it to me.  'Course, the game came out when Win95 was shortly released (yeah, that old), so Win98 compatibility wasn't a major concern.  I'm actually surprised you are having problems with it, but I'm sure we'd just say, "Recommended for DOS only" back then.